Windows 8.1 .NET Framework 3.5 error code 0x800F0906

Many applications require the .NET Framework 3.5 on my tablet runnning the Windows 8.1 build 9471. However, when I go to Control Panel > Programs and Features > Turn Windows Features on/off and try to install it, I get the message “Error code: 0x800F0906. Windows couldn’t connect to the internet to download the necessary files.” and it can’t complete the installations. How can I resolve the problem? Continue reading

Install NET Framework 3.5/3.0/2.0 on Windows 8 Pro

By default Windows 8 has built-in Microsoft .NET Framework 4.5 version. Sometimes you may want to run apps or programs, which require the older versions of .NET Framework like 3.5, on computer or Surface tablet, here is the tutorial about how to install old .NET Framework 3.5/3.0/2.0 on Windows 8 Pro OS without download .NET from the Microsoft website. Continue reading